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Introduction  

Supernovo is an application that makes end-to-end de novo sequence identification of monoclonal 
antibodies (mAbs) easier (i.e., drag and drop the raw files and start processing), generating a detailed 
project and report file.  

Note: It is highly recommended to use Supernovo on a good 64-bit multi-core computer with a 
solid state drive. A solid state drive improves performance greatly. All Supernovo results (.blgc 
files) should be saved to the solid state drive. 

Tour of De novo Sequencing Analysis Dashboard Views 

The De novo Sequencing Analysis user interface (UI), or dashboard, shown in the figure below has six 
highly interactive plot and table views: 

 

Figure 1: Six De novo Sequencing Analysis views: (1) Project table, (2) Protein coverage table, (3) 
Peptides table, (4) Ion chromatogram (XIC) plots, (5) MS2 and mass error plots, and (6) Isotope plots. 
Views can be rearranged, resized, docked, and undocked. Customized layouts can be saved and 
shared.   

1. The Project view lists the data files in use. The paired check boxes for MS files and result files 
can be used to turn on or off the records displayed in the other views. The colors of the files 
correspond to colors used in the other views. 

2. The Protein Coverage views display table data and identify sequences for peptides selected 
and filtered in the Peptides table in View 3. Bars below the sequences represent MS/MS scans. 
The bars and sequences share the colors of the corresponding MS files in the Project table in 
View 1. For a successful de novo sequence identification, understanding the Protein Coverage 
view is critical (see the Summarizing De Novo Sequencing Analysis Results section below for 
additional details). 

3. The Peptides table lists all identified and filtered peptides. Selecting a peptide row in the table 
displays the corresponding wildtype peptides, XIC chromatograms, MS2 and mass error plots, 
and isotope plots in Views 4 through 7. 
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4. The XIC plots show the ion chromatograms for the peptide and corresponding wildtype 
peptides, if present, selected in the Peptides table in View 3. The plots are shaded with the 
colors of the source MS files in the Project table in View 1. 

5. The MS2 and mass error plots show the MS2 spectrum of the peptide and corresponding 
wildtype peptides, if present, selected in the Peptides table in View 3. The peptide and wildtype 
peptide spectra share the same m/z scaling for easy comparison.  

6. The Isotopes plots show the MS1 isotope spread of the peptide and corresponding wildtype 
peptides, if present, selected in the Peptides table in View 3.  

The Wildtype peptides table lists wildtype peptides corresponding to the modified peptides selected in 
the Peptides table in View 3. Records are shaded with the colors of the source MS files in the Project table 
in View 1. This table is displayed when Windows > Show Wildtype is checked. 

Summarizing De Novo Sequencing Analysis Results 

 

Figure 2: Protein Coverage view of Supernovo project 

Protein Coverage view summarizes the de novo sequence analyses results. Right below the Depth of 
coverage info, there is de novo sequence identified and peptide coverage information. Segments of the 
sequence that are annotated in red and yellow colors need to be inspected. Right below this annotated 
sequence are the vertical bars that represent the confidence of the predicted amino acids. 
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Figure 3: Confidence in amino acid identifications 

Different colors of amino acids represent different error rates of de novo sequence analyses: 

• Red – approximately 10% error rate 

• Yellow – approximately 2% error rate 

The vertical bars for each amino acid summarize the between-residue evidence accumulated over all 
peptides from all files 

• Blue – accumulated fragmentation (MS2) evidence 

• Orange – accumulated digestion (MS1) evidence 

Project Creation 

To create a new project, go to File > New Project, or click on the  icon directly below File on the toolbar. 
Supernovo will open the New project dialog:  

 

Figure 4: New project dialog headers 

This multi-tab window allows the analyst to designate one or multiple mass spectrometer files to be 
analyzed. 

Sample input Tab  

The Sample input tab allows the user to load raw LC-MS sample files into the project. Supernovo accepts 

a variety of sample file types (Bruker: *.d, Agilent: *.d, Thermo: *.raw, Waters: *.raw, Sciex: *.wiff, 

Shimadzu *.lcd). To load a file, drag and drop one or more MS files into the project window.  
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Figure 5: Sample input tab 

Alternatively, click the Add sample button, double-click on the new row under the MS file header, click   
and browse to the file. Click Open.  

 

Figure 6: Loading MS files in the Samples table 

The sample name defaults to the file name. To change the Sample name, double-click the name and edit 

the text or click  to edit in the text editor. The sample can be removed by selecting the row and clicking 
Remove sample(s). Digestion column is ignored for Supernovo analysis but different digestion 
assignment of samples will result in different colors in the Project and Protein Coverage tables. 
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De novo options Tab 

The De novo options allows the users to input parameters for the de novo sequencing analysis. There 
are two analyses modes available in Supernovo: 

• Full analysis mode i.e., a pure de novo sequencing analysis – It is recommended to use a good 
64-bit multi-core computer with a solid state drive for the full analysis. 

• Inspect project mode i.e., quick way to test how well the MS/MS data matches to the predicted 
sequence (using a known sequence that is closely related to the sample of interest i.e., 80% 
match or more).  

 

Figure 7: De novo options tab 

• Alternate Byonic parameter file 

By default, Supernovo uses a Byonic parameter file with  

[1] Precursor mass tolerance set to 10ppm,  

[2] Fragment mass tolerance set to 20ppm,  

[3] Carbamidomethyl modification set as fixed modification on Cysteine (Carbamidomethyl / 
+57.021464 @ C | fixed) and  

[4] Fragmentation type set to QTOF/HCD.  

For a detailed list of the default Byonic parameters, open the file located at C:\Program 
Files\ProteinMetrics\PMI-
Suite\Tools\SupernovoCommandLine\Default.byparms.  

Another byparms file i.e., Cysteine58.byparms is also available at the same location. The 
Cysteine58.byparms file has the same mass tolerances, fragmentation type and other settings 
compared to the Default.byparms file, except the Carboxymethyl modification is set as fixed 
modification on Cysteine (Carboxymethyl / +58.005479 @ C | fixed). In addition to the above 2 

files, the user also has an option to input a new file by clicking  and uploading a *.byparms 
file. It is recommended to use the default Byonic parameters file as a template to make a new 
file. 

• Initial scaffold sequence 
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For human, mouse, or rat mAbs, there is no need to input an initial scaffold sequence in full 
analysis mode. For other species, it is recommended to provide an initial scaffold sequence 
that matches closely (~80% or more) with the species of interest (i.e., sample). This applies to 
both Heavy chain and Light chain: 

o Heavy chain – Text representing initial scaffold for the Heavy chain should be provided 
in the Heavy chain box. 

o Light chain – Text representing initial scaffold for the Light chain should be provided in 
the Light chain box. 

• Special options 

This field can be ignored. 

• Generate Inspection project only (do not perform de novo sequencing) 

 

Figure 8: Generate Inspection project for quick turnaround times for known sequences 

If the Generate Inspection project only checkbox is checked, the analysis will be done faster and is not 
really a pure de novo sequencing analysis. However, this option allows the user to inspect the raw data 
quickly and see if the data matches well to predicted sequences of interest. The mandatory field(s) to input 
in this mode are initial scaffold sequences of Heavy chain and Light chain. It is recommended to provide 
these sequences as close as possible to the expected sequence. The Generate Inspection project only  
option is useful for the users who run multiple experiments with the same purified protein. The users will 
have an idea about what to expect for the sequence and providing that input in the Heavy chain and Light 
chain fields will give an estimate of the depth of coverage in the constant region quickly (e.g., 5 min 
compared to several hours in full analysis mode on a 16GB system with 8 cores) 
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Additional options 

To save the edited settings from the Sample input and De novo options tabs to a configuration file, click 
the Save Preset button, enter a file name, and click Save. To load settings from a previously saved 
configuration file, click the Load Preset button, navigate to the file of interest, and click Open.  

Finally, click Process to start the de novo sequencing analysis. A Save File dialog will open for the user 
to enter a file name to save the results as a .blgc file. To cancel the project creation click Cancel. 

Log Tab 

The Log tab reports progress on the analysis:  

 

Figure 9: Log tab 

The Supernovo program does multiple iterations of refining the de novo peptide identifications and 
assembling the refined peptides into scaffolds. A detailed project file with results and summary is then 
generated. The full analysis usually takes several hours, but the user has an option to do a quick 
inspection to make sure that the data acquired matches well to the predicted sequence (see Generate 
Inspection project only in the section De novo options Tab above).  

During the initial phase of the full analysis, depth of the constant regions (of the antibody) is estimated. If 
the Depth of coverage in the constant region is greater than 20, the accuracy of the de novo sequence 
identified is high. Between 10 and 20, the accuracy is moderate. If the depth of coverage is less than 10, 
then it is advised to double-check the Byonic parameters, and if this still does not resolve the Depth of 
coverage, it is recommended to gather more data. The figure below shows the progress of Supernovo 
analysis in the Log tab. 
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Figure 10: Progress of Supernovo analysis 

Main Menu Bar 

The topmost menu bar includes four items: File, Edit, Window, and Help. 

File Menu 

The File pull-down menus manage project files and export reports and data: 

 

Figure 11: File menu 

The File menus includes items to create new projects, open previously created projects from saved files, 
save a copy of an open project, close a project (yet leave the application open), and exit De Novo 
Sequencing Analysis. Mouse over the Recent Projects menu to open a side window with a list of recently 
visited projects that can be reopened. 

The File menu functions New Project, Open Project, Close Project, Edit > Label Manager and Export 
> Report, respectively, are also available as icon buttons below the topmost menu bar: 
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Figure 12: File menu icons 

File > Export Menu 

There are also three File sub-menu items to export reports. 

 

Figure 13: File > Export menu 

File > Export > Report generates a report that includes a summary of the project files, one or more pivot 
tables (that can be visualized as bar charts, etc.), along with plot images. There are other valuable tools 
for making customizable reports and regulatory filing documents. When a report is perfected, a copy of 
the report configuration can be saved to use with other reports. If no report configuration is attached to the 
project, a default report configuration is used to generate the report.  

Edit Menu 

The Edit pull-down menu manages program settings. 

           

Figure 14: Edit menu 

Undo and Redo allow the user to undo or redo changes. These Edit menu functions are also available as 
the arrow toolbar buttons below the menu bar to the right of the Help menu. 

The Label Manager is used to add, remove and edit label values. These labels can then be assigned to 
records in the Peptides table. To add a new label, click the Add button, enter the label text, and click OK. 
To add or edit a comment to a new or existing label, select the label in the Label Manager view, and edit 
the comment in the Edit comment view. To edit a label, select it, click Edit, edit the label text, and click 
OK. To remove a label, select it, click Remove. Click OK in the main window to save all changes.   
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Figure 15: Label manager 

To add or remove labels to a record in the Peptides table, click the peptide row, scroll to the Labels column, 
click the cell in this column to open a dialog. Check or uncheck desired labels and click OK. The Label 
Manager can be opened from this dialog by a click on the Manager button. 

 

Figure 16: Adding labels in the Peptides table 

The Search Filter filters records displayed in the Peptides table according to a variety of properties and 
categories. Edit values for properties to tighten or loosen restrictions. Check additional Show categories 
to include peptides that are not true positives. Click the Peptide grouping method drop-down arrow to 
combine peptides that differ only by their charge states.   
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Figure 17: Peptide search filter 

Attach report configuration attaches a report configuration file to the project, to be used instead of the 
default report configuration. Report configuration files (graphical layouts) are generated from File > Export 

> Report and have the extension *.rptc. This menu can also be used to remove an attached report 

configuration file. 

The Peptide type filter tab allows the inclusion or exclusion of peptide modification types. Check 
modifications to include and uncheck modifications to exclude. Byologic defaults to all peptide types: 

 

Figure 18: Filtering by peptide type 

To save the edited settings from the two tabs to a configuration file, click the Save Preset button, enter a 
file name, navigate to a directory, and click Save. To load settings from a previously-saved configuration 

file, click the Load Preset button, navigate to the desired directory, select a *.blgcsfson or *.blgcsf 

file, and click Open. 

Attach report configuration attaches a report configuration file to the project, to be used in place of the 
default report configuration. Report configuration files (graphical layouts) are generated from the project 
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report opened using File > Export > Report, and then saved using File > Save to file. Configuration have 

the extensions *.rptc, *.tabc, *.lvcfg, or *.pvtcfg. This menu can also be used to remove an 

attached report configuration file. 

In-silico Peptides contains four sub-menus to import or export in-silico peptide candidates before or after 
project creation: 

 

Figure 19: Edit > In-silico Peptides menu 

• Add In -silico Peptides From CSV File opens a browser to load a *.csv file of in-silico 

candidates. Use of the correct format for the *.csv file is required. For an example of the 

correct *.csv format, see the file ImportExample.Byologic.csv in Program 
Files\ProteinMetrics\PMI-Suite\ExampleData. 

• Add Missing Via Existing Peptides identifies missing peptide sequences and fills in those 
sequences from equivalent peptides in the sample files. 

• Export In -silico to CSV exports the in-silico peptides to a *.csv file. This peptide file is then 

available for import into a different project. Enter a file name, navigate to a directory, and click 
Save. 

• Peptide Manager combines all of the In-silico functionalities from Edit > In-silico peptides with 
a color-coded preview of the project changes and enhanced control over which rows and 
columns are affected. 

o Click Export CSV is the same as Edit > In-Silico > Export CSV.  

Start and End times may differ from the previous CSV export. This is because Peptide 
Manager exports the most centered XIC start/end, while the old method exported the 
first available start/end range. The difference is considered an improvement.  

o Import CSV is the same as in Edit > Import in silico from CSV 

o Intersect CSV replaces the old menu item Edit > In-Silico > Intersect with CSV 
library. This menu item has been removed and can only be accessed from Peptide 
Manager.  

Select a CSV file using the Browse button. Matching options include Use mass and 
time and Use sequence and modifications. Set mass and time tolerances. Check 
Append unmatched to include non-intersected peptides. Click OK to return to Peptide 
Manager and select columns to review. New values will be show in red.  

o Add missing samples is the same as in Edit > In-Silico > Add missing.  

Click the button and then Apply to update the project with new in-silico peptides. These 
will be visible at the end of the list.  

Click Apply to update the project. The figure below displays a common use case: 
Feature Finder unknowns matched with in-silico content. 

Feature finder opens a dialog which includes the settings available in the Feature Finder tab during 
project creation: 



De novo Sequencing Analysis Manual v5.12              

14 

 

Figure 20: Feature finder dialog 

Add MS File(s) imports additional MS files after project creation. The MS files have extensions *.d, 

*.raw, *.wiff, *.lcd, and *.byspec2. Navigate to the desired file and click Open.  

Enable Deamidation Quantification recalculates XIC integrations to account for the interference 
between a deamidated peptide and a wildtype peptide with a similar isotope value. The wildtype integration 
is subtracted from the total to yield a “pure deamidated” XIC plot. 

 

Figure 21: Deamidation quantification subtracts the wildtype integration from the total 

Protein Annotations is used to annotate individual proteins for display in the Peptides table: 
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Figure 22: Protein Annotations 

To annotate a protein, select it in the Proteins window, click Add row, specify the starting amino acid and 
sequence length, and then enter text under Annotation value in the Protein Annotations window. The 
Find antibody CDR’s button finds antibody complementarity determining regions and displays them in 
the Protein Annotation column of the Peptides table. Click Close when finished. 

Show Byos project creation options displays the Byos workflow project creation options used to 
generate the project. This feature is only available for projects created through Byos.  

The Sequences and Processing nodes tabs open to show all the entries used in those tabs. 

Show project creation options displays in a single window the values and inputs used to create the 
current project. Apart from some import options, the data is generally read-only in these tabs. To edit 
specific functions and values, use the corresponding Edit menu items described in this section. This 
feature allows the user to save the current settings used in the project with the Save Preset button or load 
new ones with the Load Preset button. 

Advanced configuration is used to enter text commands, which are often new features still in beta 
testing. This feature is generally not used. 

Adjust colors is used to modify the default colors associated with MS samples and corresponding plots. 

Adjust MS paths is used to modify the path to the source MS file, should the file be moved. Enter or 
navigate to the new directory containing the MS file. 
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Figure 23: Editing the MS file path 

Edit PDB loads protein database files for use by Protein 3D reports. 

Window Menu 

The Window pull-down menu manages the visual layout of the user interface, and the arrangement and 
sizes of the various table and plot views: 

 

Figure 24: Window menu 

Load Layout opens a saved layout stored to files with extension *.ini. Save Layout saves the current 

layout to an *.ini file which can be used in other projects or shared with other users. Restore Default 

Layout applies the layout used when the application is first opened. 

The current layout can be customized by moving, resizing or editing the view panes. Many of the views 
(Project, Protein coverage, XIC, MS2 and mass error, and Isotope plots) can be undocked by double-
clicking on the tops of that view to create standalone windows that can be moved to another monitor. 
These views can be click-dragged to new locations in the layout. The view can also be resized by hovering 
over the vertical or horizontal edges between table and plot views so that the cursor changes to arrows: 

 or . Left click and drag the edges up or down or right or left to change the sizes of the views. 
Columns in the table views can be made larger or smaller in same manner. To reorder columns in a table, 
left click the name of the column, and drag it to the new location. To do a simple sort, left click the header 
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once to sort ascending and twice to sort descending. Mouse over a column header to see a description of 
that field. 

Column headers can be modified through the Column Header Editor dialog, opened by a right-click 
anywhere on a table column header. 

 

Figure 25: Column Header Editor 

Columns can be rearranged by dragging the header names up or down. To hide a column, uncheck the 
Visible box for that column. This dialog can also be used to specify number of significant figures and 
ranked sorting. The Window > Save Layout menu preserves these edits for future use and sharing. The 
Reset row sorting and Reset column order buttons restore the default row and column properties. 

Enable Stacked Plots can be turned on to separate the plot view into a series of normalized traces of all 
the sample data: 

   

Figure 26: Example of stacked isotope plots 

The Show Wildtype menu displays the Wildtype peptide table records and wildtype plots (XIC plots, MS2 
and mass error plots and Isotope plots) again. 
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Figure 27: Example of peptide and its wildtype isotope plots 

Show Chromatogram XIC Plot opens an undocked window displaying chromatograms for the projects. 
The traces are displayed in the colors of the samples they represent:   

 

Figure 28: Undocked Chromatogram XIC plot 

 

Server 

 

Figure 29: Server menu 
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Menu Sub Menu Action and Notes 

Server 

 Configure Configure allows Byos integration with third party servers.  

 

Currently Server > Configure is supported for the Waters UNIFI server. See the PMI UNIFI Integration 
User Guide for instructions on how to configure UNIFI integration. 

Help Menu 

The Help pull-down menu provides information about the software: 

 

Figure 30: Help menu 

The About menu shows the software version number, which is needed when reporting issues. The Log 
menu opens a log containing recent activity; this is helpful for troubleshooting problems together with 
Protein Metrics, Inc. staff via support@proteinmetrics.com. Support Package opens a dialog to generate 
a comprehensive set of files to better enable Protein Metrics to troubleshoot problems. Click Review & 
edit the package to generate a directory of individual files as directed. Click Compress to generate a zip 
file of this support directory. An information box indicates where the zip file can be found and gives a link 
for support@proteinmetrics.com.  Open User Guides opens the installed folder with the manuals and 
quick start guides for Protein Metrics, Inc. software, including Supernovo. Check For Updates will report 
if an online update is available for installation. Online Resources opens the Protein Metrics, Inc. Secure 
Resources webpage containing a variety of technical pages and tutorials related to Protein Metrics, Inc. 
software. Register is used to activate the software upon first use. 

Table Menus 

The menu bars at the top of the three table views, Project, Peptides, and Wildtype peptides, share icons 
that manage hierarchical lists and filter on data. 

• The  icon expands rows to show “sub-rows”. 

• The  icon collapses rows to hide sub-rows. The use of sub-row depends on the table. For 
example, in the Peptides table, a row is a peptide record and a sub-row is the data resulting from 
an individual sample that contained the peptide. 

• The  icon exports the table to a .csv file for opening with Excel. 

• The  icon opens a dialog to create custom filters for that data table. (A single column filter can 
also be set by right-clicking on an entry in the column.) Select a column in the first cell, select an 
operator in the second cell, and enter text in the third cell. A second filter row becomes available 
for further entry. Click the red X after a filter row to delete it. Custom filters allow masses to be 

mailto:support@proteinmetrics.com
mailto:support@proteinmetrics.com
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filtered by mass range, annotation, intensity, and so forth. Custom filters can be stored with the 
project document or exported and imported using the Presets dropdown. 

• The  cell filters the entered text across the content of all columns in the protein 
and peptide tables. The records are filtered automatically as text is entered. Click the  icon to 
search the string as a whole word or as case sensitive. 

• To sort the contents of a column by ascending value, click the column header. Click the column 
header again to sort by descending value. 

Table Right-Click Menus 

The Project, Protein Coverage, Peptides, and Wildtype peptides tables have context menu items revealed 
by a right-click on the rows within the tables. (Recall that a right-click on the header of these tables opens 
the Column Header Editor dialog.) 

 

Figure 31: Table right-click menus 

• Export table to CSV saves the table content and headers to a .csv file using parameters 
chosen in the Export data dialog. 

• Copy selected row(s) to clipboard copies selected table rows, with their headers to be 
available for pasting into another application. (This menu is not available in the Protein Coverage 
table.) 

Table context menus contain a set of query options for searching the clicked text value using any of the 
available search operators. This is an easy way to filter a table based on a specific field value. 

 

Figure 32: Search table values through a right-click menu 
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Project Table 

The Project table contains information about the MS samples and results files: 

 

Figure 33: Project table 

To display or remove the MS sample and result combination, check or uncheck the box at left of either a 
sample or result record. To edit a MS sample or result alias name, right-click the entry to edit under the 
Alias Name header, click Edit selected row(s), edit the name, and then click OK. 

Protein Coverage Table and Menu 

The Protein Coverage table displays peptide sequences and corresponding protein coverage. Different 
samples are assigned different colors: 
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Figure 34: Protein Coverage table 

The different colors within the colored bars indicate the presence of peptide modifications at those 
positions. (The colors used are chosen for contrast and do not reflect the colors assigned to the MS sample 
files.) The bar charts summarize between-residue evidence accumulated over all peptides from all 
samples.  

The Protein Coverage table also includes the following specialized menu icon buttons: 

• The  icon opens the Protein coverage rendering options dialog: 
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Figure 35: Protein coverage rendering options 

• The  icon turns on and off the display of the tabular protein coverage data. 

The Protein Coverage view has context menu items revealed by a right-click on the graphical portion of 
the display: 

 

Figure 36: Protein Coverage right-click menu 

• Rendering options also opens the Protein coverage rendering options dialog show above. 

• Export coverage creates a *.png file of the graphical protein coverage display. 

• Export to FASTA creates a *.fasta file of the proteins found in the Protein Coverage view. 

The *.fasta file is then available for import into new projects. 

Amino acids that should be inspected are shaded 

• Red – approximately 10% error rate 

• Yellow – approximately 2% error rate 
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Peptides Table and Menu 

The Peptides table contains detailed information about all identified peptides: 

 

Figure 37: Peptides table 

The Peptide table organizes records in the following hierarchy: Peptide > Sample > Charge state (if 
combined) > MS2 scan. Records in the Peptide table can be modified directly by the user for three fields: 
Validate, Comment and Labels. In the Validate field, the user selects between “True-positive”, “False-
positive” and “Uncertain”. Comments are input directly. Values for Labels are selected from a list. To create 
new labels to use in the Labels field, see Edit > Label Manager. 

Note: The MS1 correlation score compares the measured MS1 isotope distribution to the theoretical 
distribution calculated using cosine similarity. A score of 1 is a perfect match. 

In addition to the usual table menu buttons, the Peptides table contains the  icon button which opens 
the same Search Filter dialog that is opened by the Edit > Search Filter menu. Within the Search Filter, 
two other tabs to filter out the peptides and peptide types are present. The user has an option to filter out 
the false positives by clicking Peptide filters tab and unchecking False-positive box within the Show tab 
and clicking OK. 
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Figure 38: Peptides table - Search filter menu 

The text filter entry box allows the records to be filtered based on the occurrence of the given text string 
searched across all fields. 

The Peptides table has context menu items applicable to specific peptides. The menu is revealed by a 
right-click on a peptide cell in the table: 

 

Figure 39: Peptides table right-click menus 

• Show/Edit alternatives displays a table of alternative MS2 identifications (with different 
sequences and/or modifications) for the selected peptide, along with their scores: 
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Figure 40: Peptide alternatives table 

Select an alternative peptide and click Replace to replace the selected peptide in the Peptides 
table. Protein coverage, observed and calculated masses and m/z ratios all are updated. 

• Show protein summary opens a table with protein data for that peptide: 

 

Figure 41: Protein summary 

• Set XIC time interval allows the user to edit the XIC start and end times for that peptide and to 
set the time tolerance (time warp) to improve performance: 

 

Figure 42: Set XIC time interval 

• Create new peptide from current makes a copy of that peptide. This allows XIC plots to be 
split according to separate integrations. The user edits the start and end times and the charge of 
the peptide before the copy is created: 
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Figure 43: Create new peptide from current 

• Edit proposed XIC splits opens a dialog to enter pairs of time ranges to split XIC plots for that 
peptide record into two or more chromatograms: 

 

Figure 44: Edit proposed XIC splits 

After a click on the OK button, the Peptides table record field XIC proposals is updated with the 
time range entries. The split must be applied to take effect. 

• Apply proposed XIC splits separates a record in the Peptides table into two or more records 
using the time ranges entered using the Edit proposed XIC splits function.  

• Add to XIC overlay adds the selected Peptides table record (subject to the right-click) or 
collection of records as an overlay to the XIC plots view mapped to the same time axis. When 
this function is applied to a collection of records in the table, all the records below it are added to 
the XIC plots view. 

• Remove from XIC overlay removes the overlay from the selected Peptides table record 
(subject to the right-click) from the XIC plots view. 

• Clear overlays removes all sample overlays from the XIC plots view. 

Wildtype Peptides Table and Menu 

The Wildtype peptides table contains detailed information about naturally occurring or wildtype peptides 
associated with the peptide selected in the Peptides table: 
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Figure 45: Wildtype Peptides table 

The Wildtype peptides table has one context menu item specific to wildtype peptides. The menu is 
revealed by a right-click on a wildtype peptide cell in the table. Set primary wildtype marks that record 
as the primary wildtype peptide for the selected record in the Peptides table. 

Plot Menus  

The menu bars at the top or sides of the three plot views, XIC, Isotope, and MS2 and mass error, share 
icons that support generic operations on plots. These icons appear in almost all Protein Metrics, Inc. 
software products. 

• The  icon resets the plot to default zoom level. Shortcut = double left-click. 

• The  icon enables zooming in. The cursor changes to this icon. Drag across the range of the 
plot to display to zoom to that x-range. By default, the plot’s y-range scales according to the 
maximum y-value within the x-range, but the software also supports freeform zooming as 

enabled under the  icon. 

• The  icon enables zooming out. Click anywhere in the plot to zoom out. 

• The  icon enables moving (panning) across the plot. The cursor changes to this icon. Click 
the plot and drag up or down, right or left to view a part of the plot that is off-screen. 

• The  icon locks the x-axis for stacked plots in a plot view to use the same ranges. Unselecting 
this allows stacked plots to apply independent x-axis ranges. 

• The  icon performs an undo of the last zoom step. Shortcut = Shift-left arrow key. 

• The  icon performs a redo of the last zoom step. Shortcut = Shift-right arrow key. 

• The  icon manages how plots are displayed (render options), as well as zoom modes. The 
Render and zoom options include: 
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Figure 46: Render and zoom options 

o Show x values and Show y values display the x- or y-coordinates beside plot peaks to 
the chosen number of significant figures.  

o Show delta: when checked, displays the x or y differences from a reference peak when 
the cursor hovers over a peak tip. 

o Show centroided peaks darkens the peak positions that are determined to be 
centroided. 

o Show plot title displays the title of the plot, as generated from field values.  

o Label orientation, when checked, orients labels to some angle other than horizontal. 

The Zoom and pan mode options include: 

o Match x-range, when checked and followed by reset zoom (click on the  icon) the 
peptide and wildtype peptide plots are redrawn using the same x-axis values. 

o Free form mode to manually select the desired y range as well as x range. 

o Auto scale mode to select only the x range (the y range is then adjusted to the value of 
the highest peak). 

o Locked view mode to keep the current x range (for either m/z and/or m) when moving 
between elution peaks. 

o Locked x-axis mode turns off autoscaling for the x-axis (but not the y-axis) and applies 
the current x-axis scale across all Peptide table selections. 
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Under Scrolling, the Visibility setting controls display of the scroll bars:  

o Always on displays scroll bars even when the full plot is shown. 

o Always off turns off display of the scroll bars even when a partial plot is shown. 

o Show as needed displays scroll bars only when a partial plot is shown. 

Plot Right-Click Menus 

The XIC, MS2 and mass error, and Isotope plots have a variety of context menus for plot styling and 
exporting revealed by a right-click on the plots: 

 

Figure 47: Plot right-click menus, [1] for MS2 and mass-error plots and [2] for XIC/Isotope plots 

Figures exported can be useful for reports, publications, regulatory filings, or internal communications. 
There are many options for rendering and exporting so that the user has much freedom to prepare a plot 
or figure style as needed. 

• Adjust X-Y axis limits opens a dialog for the user to manually edit the plots x and y maxima 

and minima. This is a less convenient but more precise (and reproducible) alternative to the  

and  icons. 

• Export image allows the user to save the plot as a *.pdf file or as a *.png or *.wmf image 

file. It opens the Plot Exporting Settings dialog, which controls image size, file name and 
folder, and x and y minima and maxima: 
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Figure 48: Plot export settings 

Sometimes a user wishes to display a wide range across the x-axis and yet retain significant 
detail. This can be done by breaking up the plot into a series of panels. The Add segment 
button creates segments with user-defined x and y values. A series of these segments 
eliminates unneeded portions of the plot and increases the effective detail in the image. This is 
also a useful function for automated reporting. The Re-segment button allows edits to the 
reported x and y minima and maxima for existing segments. 

Note: Image exports also support *.png and *.wmf image formats. In the file name cell, 

change the selected extension and click Save: 
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Figure 49: Plot export as a *.png file or a *.wmf file 

• Export image series also opens the Plot Exporting Settings dialog, except that the segments 
are prepopulated with six equal sized segments. This simplifies the edits of the segments. The 
Add segment and Remove segment buttons control the number of segments that divide up the 
plot. 

• Export all also opens the Plot Exporting Settings dialog, except that the wildtype peptide plots 
are exported along with the peptide plots. Segment editing functions are disabled for this option. 

• Export to CSV exports the plot trace x-y points to a *.csv file. 

• Copy to clipboard (all) enables pasting the plot image into another application. 

• Avoid label collision staggers the label text to reduce overlap. 

• Rendering options controls how a plot is displayed in the application. It includes several sub-
menus: 

 

Figure 50: Rendering options menu 
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o Preconfigured sub-menus control what is displayed in the plots. Default mode displays 
the trace, peak labels and plot title. Show all peak labels does exactly that. Trace only 
turns off the peak labels and plot title. 

o Show x grid lines turns on and off the x grid lines. 

o Show y grid lines turns on and off the y grid lines. 

o Show tracker displays a vertical dotted line that follows the cursor when moved in the 
plot. This allows a more precise determination of the X and Y positions of the cursor. 

o Y-tick label notation toggles between y-axis notation options of absolute amounts or as 
percentages of the highest peak. 

o Adjust font sizes controls the font size for each type of text on the plot. 

o Plot styles allows changes to the graphic styling of the plot, including trace width, axis 
width, and total m/z dot colors to be used. 

o First Layer (XIC and Isotope plots only) reveals sub-menus to turn on and off the 
display of traces, integrations, and labels in the plots. The show/hide all sub-menu turns 
all on or off. 

 

Figure 51: Rendering options > First Layer menu 

• Adjust Offset (XIC plots only) sets the x-axis offset between multiple plots as percentage of the 
highest peak when the top-level menu Window > Enable Stacked Plots is checked. 

• Show/hide sample name (XIC and Isotope plots only) controls whether to display the sample 
names or not for both individual and stacked plots. 

• Sample name position (XIC and Isotope plots only) reveals sub-menus to position the 
sample name with respect to the graphs. 
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Figure 52: Sample name position sub-menu 

XIC Plots and Menu 

The XIC plots view displays chromatograms for specific regions of the peptides and wildtype peptides 
associated with the record selected in the Peptides table:  

 

Figure 53: XIC Plots including wildtype peptides 

In addition to the menu icon functions shared by all the plot views, there are some functions specific to 
XIC plots: 

• The  icon turns plot annotations on or off. In the XIC plots, annotations are displayed as 
circles at the base of the chromatograms. Dark red circles represent the position of currently 
displayed MS2 scans. Light red circles represent the position of other MS2 scans with the same 
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identification. Light gray circles represent the position of MS2 scans with the same precursor 
mass as the selected peptide, but with different attribution. Hover over the circles and the 
associated sequence ID and value are displayed. Note that the cursor changes to a hand. Click 
the circle and the corresponding Peptides table row is selected and the views are updated to 
display for that record.  

• The  icon is used to compute the XIC plot integration for a specified time range. A dialog 
opens to enter start and end times. 

• The  icon enables MS scan extraction. This displays isotope values derived from the XIC 
plot. A blue vertical line appears in the XIC plots view. As the line is dragged across the XIC 
trace, the Isotope plots view is updated to show the MS scan for that XIC time value. Two new 

icons appear on the Isotope plots menu bar in this mode: The  icon clears the extracted MS 

scan and restores the original isotope plots. The  icon saves the extracted MS scan to the 
project document. 

Isotope Plots and Menu 

The Isotopes plots display the peptide isotope (m/z scan) for the selected Peptides table record:   

 

Figure 54: Isotope plots including wildtype peptides 

In addition to the menu icon functions shared by all the plot views, there are some functions specific to 
XIC plots: 

• The  Show/hide annotations icon turns on and off the display of the molecular weight for the 
primary peptide beside a blue dot that identifies the peak with that calculated value. 

MS2 and Mass Error Plots and Menu 

The MS2 and mass error plots display plots of the MS2 peptide fragments with the corresponding m/z 
mass error table: 
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Figure 55: MS2 and mass error plots including wildtype peptides 

The MS2 plots are identified by Scan ID. The plots are colored blue for N-terminus b ions and red for C-
terminus y ions. Other fragments, including c and z ions are colored green 

In addition to the menu icon functions shared by all the plot views, there are some functions specific to 
MS2 and mass error plots: 

• The  icon switches between the default plot view and the mass table view: 
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Figure 56: MS2 and mass error plots: mass table view 

The reported fragment data that was confirmed in the analysis is displayed in red bold font. 

Unconfirmed fragment data is displayed in black font. In this view, the  icon switches the view 

back to MS2 plots. The  icon copies the content of this table to the clipboard. 

• The  icon switches between showing and hiding the b and y ion labels. The icon is 
accompanied by a drop-down arrow that reveals three sub-menus: 

o Open annotation options opens a dialog that allows the user to set options for 
determining the assignment of the MS2 annotations: 

 

Figure 57: MS2 fragment annotation options 
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The maximum number of peaks per 100 m/z and MS2 mass-accuracy tolerance options 
can use presets for Low accuracy, High accuracy, or Custom, in which the user sets 
these values. The dialog defaults to the Auto preset, in which the software determines 
the MS2 fragment annotation settings. 

o Remove fragment coverage cache clears the existing cache of detected fragments 
used for the protein fragment coverage rendering. 

o Export fragment to CSV, exports the fragment sequence to a *.csv file. 

• The  icon turns on or off the fragment sequences displayed to the right of the plots. 

The MS2 and mass error plots view has two specific context menu items revealed by a right-click in the 
plot:  

• Apply peak filtering opens a dialog that allows the filtering of peaks by an entered signal-to-
noise ratio value. 

 

Figure 58: Peak filtering by signal-to-noise ratio 

• Combine MS2 spectra (MS2 and mass error plots only) sums the MS2 Plots for all the peptides 
for a selected row in the Peptides table. The title of the plot updates to show the counts of the 
peptide scans in the combined MS2 plot: 

 

Figure 59: MS2 plots after Combine MS2 spectra is applied 
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Appendix 

Leucine/Isoleucine differentiation with EThcD data 

The accuracy in differentiating leucine (L) and isoleucine (I) in mass-spectrometry based de novo 
sequencing analysis is difficult as the side chains of these amino acids are isomers and have the same 
mass of 113.08406 Da. However, using the samples from multiple proteases and running analysis on 
instrument that can generate EThcD data, the amino acids I/L can be differentiated with sophisticated 
analysis. Supernovo uses the characteristic EThcD fragment ion peaks and the digestion or lack of 
digestion of C-terminal of these amino acids (I/L) to distinguish Isoleucine (I) from Leucine (L).  

Besides the .blgc file (Supernovo project file), there is an .html file (with the same base name as the 

project) that contains some additional information. For the EThcD analysis, this .html file (at the bottom 

section) summarizes the confidence of the I/L differentiation and other metrics and graphics. In the below 
figure, the actual sequence (highlighted in grey), the de novo predicted sequence (highlighted in black) 
and an additional row showing the confidence of I/L is shown. Different colors of I/L represent different 

confidences. Green is high confidence; Orange is medium confidence; and Red is low confidence. Regions 

highlighted in Yellow are complementarity determining regions (CDRs) of the antibody. 

 

Figure 60: NIST mAb heavy chain - de novo identification from Supernovo analysis 
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Figure 61: NIST mAb light chain - de novo identification from Supernovo analysis 


